Unable to run the executables. Getting "bash: ./websocket_callee: No such file or directory error"

hi ,

I am working on WAMP and crossbar. I tried compiling and running the C++ example from GitHub - crossbario/autobahn-cpp: WAMP for C++ in Boost/Asio here only I changed one thing that Boost library installation I used “$: sudo apt-get install libboost-all-dev”. Later I did cmake and make and tried running the executables by “./filename” instaruction (eg: ./publisher) through terminal but I am getting "bash: ./websocket_callee: No such file or directory " error.

below am attaching the screenshot.

Any suggestion will help me a lot.

autobahn_C |690x362 Preformatted text

Also below is the my output on running the executable and its details:

  siddhu@siddhu:~/autobahn-C+++_client_examples/build/examples$ ls
  callee      cmake_install.cmake       provide_prefix  uds
  caller      libexamples_parameters.a  publisher       wampcra
  CMakeFiles  Makefile                  subscriber      websocket_callee
  bash: ./websocket_callee: No such file or directory
  siddhu@siddhu:~/autobahn-C+++_client_examples/build/examples$ ldd     
linux-vdso.so.1 (0x00007fff30095000)
libcrypto.so.1.1 => /usr/lib/x86_64-linux-gnu/libcrypto.so.1.1 (0x00007f9849788000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f9849569000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f98491e0000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f9848def000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f9848beb000)
/lib/ld64.so.1 => /lib64/ld-linux-x86-64.so.2 (0x00007f9849c53000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f984884d000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f9848635000)