TLS 1.3 from iOS?

Google and Apple have been upping their requirements for security in networking protocols, and the latest version of iOS 15.2 requires a connection using TLS 1.3. Can anyone here comment whether the current crossbar.io server will support that? Currently I am using MDWamp Obj-C client; will TLS 1.3 work with that combination?

Also wondering if someone can comment on the ongoing support for WAMP. The client options for iOS seem to be getting a bit long in the tooth. MDWamp hasn’t been updated in 7 years, and there doesn’t seem to be any good clients in Swift. What does support look like for WAMP in the future?

Hi,

rgd TLS v1.3 in Crossbar.io: support TLS v1.3 · Issue #1776 · crossbario/crossbar · GitHub

rgd ongoing support for WAMP on Obj-C: yes, we’d love to! however, as WAMP community, we depend on resources to actually maintain/support stuff like this.

fwiw, we’ve recently started an effort to bring WAMP related OSS projects under a common foundation which would be able to collect grants/sponsorships

if you are specifically interested in MDWamp as a user, you might contact those developers, maybe they are interested in joining the WAMP DAO …

cheers,
/Tobias

Thank you for the suggestion and duly noted, I didn’t know about this. Confirmed working with iOS 15.2, MDWamp, RHEL 7 (!!), TLS.

1 Like